首页前端开发HTML2012 ACM/ICPC Asia Regional Tianjin Online hdu 4287 map和char[]的合作应用

2012 ACM/ICPC Asia Regional Tianjin Online hdu 4287 map和char[]的合作应用

时间2024-01-25 12:44:16发布访客分类HTML浏览199
导读:收集整理的这篇文章主要介绍了html5教程-2012 ACM/ICPC Asia Regional Tianjin Online hdu 4287 map和char[]的合作应用,觉得挺不错的,现在分享给大家,也给大家做个参考。小宝典致力于...
收集整理的这篇文章主要介绍了html5教程-2012 ACM/ICPC Asia Regional Tianjin Online hdu 4287 map和char[]的合作应用,觉得挺不错的,现在分享给大家,也给大家做个参考。小宝典致力于为广大程序猿(媛)提供高品质的代码服务,请大家多多光顾小站,小宝典在此谢过。

Intelligent IME
Time LimIT: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
total Submission(s): 386    Accepted Submission(s): 203


PRoblem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be sPEcific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o   
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we Press the button 9, 4, 6, 4, then the input method will choose From an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 = N = 5000), M (1 = M = 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
1
3 5
46
64448
74
go
in
night
might
gn
 

Sample Output
3
2
0
 

Source
2012 ACM/ICPC Asia Regional Tianjin Online
 

Recommend
liuyiding
 
题意:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o   
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
 
a 是2 b是2 c 是2  d是3 e是3.。。。。。。。
把字符串转化以后的数字串  看在上面出现了几次
理所当然 map解决
这题主要是练习 map 和char[] 的合作
 
[htML] 
#includestdio.h>  
#includestring.h>  
#includestring>  
#includeiostream>  
#includemap>  
using namespace std;  
char key[27]="22233344455566677778889999";  
char num[5005][10],word[5005][10];  
int main() 
{  
    int t;  
    scanf("%d",& t);  
    while(t--) 
    {  
        int n,m,i,j,len;  
        map string,int> M;  
        scanf("%d%d",& n,& m);  
        for(i=0; in; i++) 
        {  
            scanf("%s",num[i]);  
        }  
        mapstring,int> ::iterator it;   
        for(i=0; im; i++) 
        {  
            scanf("%s",word[i]);  
            len=strlen(word[i]);  
            for(j=0; jlen; j++) 
                word[i][j]=key[word[i][j]-'a'];  
            it=M.find(word[i]);  
            if(it==M.end()) 
                M[word[i]]=1;  
            else 
                M[word[i]]++;  
        }      
        for(i=0; in; i++) 
        {  
            it=M.find(num[i]);  
            if(it==M.end()) 
                printf("0/n");  
            else 
                printf("%d/n",M[num[i]]);  
        }  
    }  
    return 0;  
}  

Intelligent IME
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 386    Accepted Submission(s): 203


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o   
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 = N = 5000), M (1 = M = 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
1
3 5
46
64448
74
go
in
night
might
gn
 

Sample Output
3
2
0
 

Source
2012 ACM/ICPC Asia Regional Tianjin Online
 

Recommend
liuyiding
 
题意:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o   
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
 
a 是2 b是2 c 是2  d是3 e是3.。。。。。。。
把字符串转化以后的数字串  看在上面出现了几次
理所当然 map解决
这题主要是练习 map 和char[] 的合作
 
[html] 
#includestdio.h>  
#includestring.h>  
#includestring>  
#includeiostream>  
#includemap>  
using namespace std;  
char key[27]="22233344455566677778889999";  
char num[5005][10],word[5005][10];  
int main() 
{  
    int t;  
    scanf("%d",& t);  
    while(t--) 
    {  
        int n,m,i,j,len;  
        map string,int> M;  
        scanf("%d%d",& n,& m);  
        for(i=0; in; i++) 
        {  
            scanf("%s",num[i]);  
        }  
        mapstring,int> ::iterator it;   
        for(i=0; im; i++) 
        {  
            scanf("%s",word[i]);  
            len=strlen(word[i]);  
            for(j=0; jlen; j++) 
                word[i][j]=key[word[i][j]-'a'];  
            it=M.find(word[i]);  
            if(it==M.end()) 
                M[word[i]]=1;  
            else 
                M[word[i]]++;  
        }      
        for(i=0; in; i++) 
        {  
            it=M.find(num[i]);  
            if(it==M.end()) 
                printf("0/n");  
            else 
                printf("%d/n",M[num[i]]);  
        }  
    }  
    return 0;  
}  

觉得可用,就经常来吧! 欢迎评论哦! html5教程,巧夺天工,精雕玉琢。小宝典献丑了!

声明:本文内容由网友自发贡献,本站不承担相应法律责任。对本内容有异议或投诉,请联系2913721942#qq.com核实处理,我们将尽快回复您,谢谢合作!

divHTMLletMappost-format-gallerythis

若转载请注明出处: 2012 ACM/ICPC Asia Regional Tianjin Online hdu 4287 map和char[]的合作应用
本文地址: https://pptw.com/jishu/586530.html
高通蓝牙脚本 HTML div css 强制 换行 不换行

游客 回复需填写必要信息